Qualtrics - Unavailable
Incident Report for Duke IT
Resolved
The issue with Qualtrics has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 6 months ago. Apr 16, 2018 - 09:11 EDT
Identified
Qualtrics is unavailable for all users.

OIT staff have contacted the vendor and have confirmed that the vendor is working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Qualtrics visit OIT's web page: https://oit.duke.edu/what-we-do/applications/qualtrics
Posted 6 months ago. Apr 16, 2018 - 08:47 EDT
This incident affected: Collaboration and Communication (Qualtrics).