Office 365 - Managing Distribution Groups
Incident Report for Duke IT
Resolved
The issue with distribution groups in Office 365 has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted May 01, 2017 - 10:29 EDT
Identified
Users are unable to make changes/edits to their Office 365 distribution groups.

The vendor (Microsoft) is working to restore service. If you have questions about this issue or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Office 365 visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Apr 24, 2017 - 13:32 EDT
This incident affected: Collaboration and Communication (Microsoft 365).