Finesse Agent Login Tool - Possible Login Issues
Incident Report for Duke IT
Resolved
This incident has been resolved.
Posted Mar 17, 2017 - 14:33 EDT
Update
If the login issue persists after clearing the browser cache try accessing Finesse via the following URL:

https://fitz-finesse-01.oit.duke.edu
Posted Mar 17, 2017 - 09:28 EDT
Monitoring
Due to an application upgrade last evening call center agents may need to clear their browser cache in order to connect to the Finesse Agent Login Tool.

If you have questions about this posting or would like to report additional service issues please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about the Finesse Agent Login Tool visit OIT's web page: https://oit.duke.edu/what-we-do/applications/finesse-agent-login-tool
Posted Mar 17, 2017 - 06:56 EDT