Comodo SSL Certificate Issuance - Service Issue
Incident Report for Duke IT
Resolved
The issue with SSL certificate issuance has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Sep 17, 2018 - 11:57 EDT
Identified
The vendor, Comodo, is working towards a resolution but unfortunately there is no estimated time to resolution.
Posted Sep 17, 2018 - 09:42 EDT
Investigating
Comodo, the vendor used to provide SSL certificates, appears to be experiencing delays with the issuance of new SSL certificates. This does not impact already issued SSL certificates.

The vendor is aware of the problem and is working towards a resolution. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about SSL certificates visit OIT's web page: https://oit.duke.edu/what-we-do/applications/ssl-certificate
Posted Sep 17, 2018 - 08:34 EDT
This incident affected: Other (Other).